Support Widget Experience Degraded - Please email support@salto.io

Incident Report for Salto

Resolved

This incident has been resolved and the support widget should work as intended across browsers.
Posted Mar 17, 2025 - 22:44 UTC

Investigating

We are currently investigating and issue with our Support Widget not working as expected in some browsers or situations. You can email us at support@salto.io and we'll make sure you get a response.
Posted Mar 17, 2025 - 19:31 UTC