User might get a "Something went wrong" screen
Incident Report for Salto
Resolved
This incident has been resolved.
Posted Feb 05, 2024 - 10:40 UTC
Identified
Users might get a "Something went wrong" screen. If you bump into this issue, we ask you to refresh your page for now. We are aware of this issue and working on a fix.
Posted Jan 30, 2024 - 18:27 UTC